Clang Project

clang_source_code/test/CXX/dcl.dcl/dcl.spec/dcl.inline/p5.cpp
1// RUN: %clang_cc1 -std=c++1z -verify %s
2
3void x() {
4  inline int f(int); // expected-error {{inline declaration of 'f' not allowed in block scope}}
5  inline int n; // expected-error {{inline declaration of 'n' not allowed in block scope}}
6  static inline int m; // expected-error {{inline declaration of 'm' not allowed in block scope}}
7}
8
9inline void g();
10struct X {
11  inline void f();
12  // FIXME: This is ill-formed per [dcl.inline]p5.
13  inline void g();
14  inline void h() {}
15};
16