Clang Project

clang_source_code/test/CXX/dcl.dcl/dcl.spec/dcl.stc/p9.cpp
1// RUN: %clang_cc1 -verify %s
2
3struct S; // expected-note 2{{forward declaration of 'S'}}
4extern S a;
5extern S f(); // expected-note {{'f' declared here}}
6extern void g(S a);
7
8void h() {
9  g(a); // expected-error {{argument type 'S' is incomplete}}
10  f(); // expected-error {{calling 'f' with incomplete return type 'S'}}
11}
12