1 | // RUN: %clang_cc1 -std=c++11 -fsyntax-only -verify %s |
---|---|
2 | |
3 | // -- The argument list of the specialization shall not be identical |
4 | // to the implicit argument list of the primary template. |
5 | |
6 | template<typename T, typename ...Types> |
7 | struct X1; |
8 | |
9 | template<typename T, typename ...Types> |
10 | struct X1<T, Types...> // expected-error{{class template partial specialization does not specialize any template argument; to define the primary template, remove the template argument list}} |
11 | { }; |
12 | |
13 | |
14 |