Clang Project

clang_source_code/test/CXX/temp/temp.spec/cxx1y-variable-template-no-body.cpp
1// RUN: %clang_cc1 --std=c++1y -fsyntax-only -verify %s
2// RUN: cp %s %t
3// RUN: not %clang_cc1 --std=c++1y -x c++ -fixit %t -DFIXING
4// RUN: %clang_cc1 --std=c++1y -x c++ %t -DFIXING
5
6template<typename T> 
7T pi = T(3.1415926535897932385); // expected-note {{template is declared here}}
8
9template int pi<int>;
10
11#ifndef FIXING
12template float pi<>; // expected-error {{too few template arguments for variable template 'pi'}}
13template double pi_var0; // expected-error {{explicit instantiation of 'pi_var0' does not refer to a function template, variable template, member function, member class, or static data member}}
14#endif
15
16// Should recover as if definition
17template double pi_var = 5; // expected-error {{variable cannot be defined in an explicit instantiation; if this declaration is meant to be a variable definition, remove the 'template' keyword}}
18#ifndef FIXING
19template<typename T> 
20T pi0 = T(3.1415926535897932385); // expected-note {{previous definition is here}}
21
22template int pi0 = 10; // expected-error {{variable cannot be defined in an explicit instantiation; if this declaration is meant to be a variable definition, remove the 'template' keyword}} \
23                          expected-error{{redefinition of 'pi0' as different kind of symbol}}
24#endif
25
26template<typename T> 
27T pi1 = T(3.1415926535897932385); // expected-note 0-2 {{here}}
28
29// Should recover as if specialization
30template float pi1<float> = 1.0;  // expected-error {{explicit template instantiation cannot have a definition; if this definition is meant to be an explicit specialization, add '<>' after the 'template' keyword}}
31namespace expected_global {
32#ifndef FIXING
33  template int pi1<int> = 10;  // expected-error {{explicit template instantiation cannot have a definition; if this definition is meant to be an explicit specialization, add '<>' after the 'template' keyword}} expected-error {{must occur at global scope}}
34#endif
35}
36