1 | // RUN: %clang_cc1 -fsyntax-only -verify %s |
---|---|
2 | |
3 | template<class T> class X; |
4 | template<> class X<int>; // expected-note{{forward}} |
5 | X<int>* p; |
6 | |
7 | X<int> x; // expected-error{{incomplete type}} |
8 |
1 | // RUN: %clang_cc1 -fsyntax-only -verify %s |
---|---|
2 | |
3 | template<class T> class X; |
4 | template<> class X<int>; // expected-note{{forward}} |
5 | X<int>* p; |
6 | |
7 | X<int> x; // expected-error{{incomplete type}} |
8 |