Clang Project

clang_source_code/test/CXX/temp/temp.spec/temp.expl.spec/p10.cpp
1// RUN: %clang_cc1 -fsyntax-only -verify %s
2
3template<class T> class X; 
4template<> class X<int>; // expected-note{{forward}}
5X<int>* p; 
6
7X<int> x; // expected-error{{incomplete type}}
8