Clang Project

clang_source_code/test/CXX/temp/temp.spec/temp.expl.spec/p11.cpp
1// RUN: %clang_cc1 -fsyntax-only -verify %s
2// expected-no-diagnostics
3
4template<class T> class Array { /* ... */ }; 
5template<class T> void sort(Array<T>& v);
6
7// explicit specialization for sort(Array<int>&) 
8// with deduced template-argument of type int 
9template<> void sort(Array<int>&);
10