Clang Project

clang_source_code/test/CXX/temp/temp.spec/temp.inst/p11.cpp
1// RUN: %clang_cc1 -verify -emit-llvm-only %s
2
3// rdar://problem/7838962
4namespace test0 {
5  template<typename T> unsigned f0() {
6    return T::MaxSize; // expected-error {{'int' cannot be used prior to '::'}}
7  };
8  template<typename T> struct A {
9    void Allocate(unsigned Alignment
10                    = f0<T>()) // expected-note {{in instantiation}}
11    {}
12  };
13  void f1(A<int> x) { x.Allocate(); }
14  
15}
16